If you see deprecation warnings it means that you are still using Indexhibit version 0.70 You should apply the Indexhibit v0.73 Update patch

The update also fixes a security issue